Troubleshooting steps with UCS boot from iSCSI and CHAP

This is an update to a previous article that shows the correct output for the UCS Adaptors if two way CHAP is enabled on a boot from iSCSI Cisco UCS Blade.

Image

 

adapter 1/1/1 (mcp):2# iscsi_get_config

 

vnic iSCSI Configuration:

—————————-

vnic_id: 13

link_state: Up

Initiator Cfg:

initiator_state: ISCSI_INITIATOR_READY

initiator_error_code: ISCSI_BOOT_NIC_NO_ERROR

vlan: 0

dhcp status: false

IQN: iqn.1987-05.com.cisco:A:XXX:7

IP Addr: 1.1.1.1

Subnet Mask: 255.255.255.0

Gateway: 0.0.0.0

CHAP Name: chapin

CHAP Secret: ********

 

Target Cfg:

Target Idx: 0

State: ISCSI_TARGET_READY

Prev State: ISCSI_TARGET_DISABLED

Target Error: ISCSI_TARGET_NO_ERROR

IQN: iqn.1992-08.com.netapp:sn.XXXXX

IP Addr: 1.1.1.2

Port: 3260

Boot Lun: 0

Ping Stats: Success (12.089ms)

 

Session Info:

session_id: 0

host_number: 0

bus_number: 0

target_id: 0

CHAP Name: chapout

CHAP Secret: ********

 

 

vnic_id: 14

link_state: Up

 

Initiator Cfg:

initiator_state: ISCSI_INITIATOR_READY

initiator_error_code: ISCSI_BOOT_NIC_NO_ERROR

vlan: 0

dhcp status: false

IQN: iqn.1987-05.com.cisco:B:XXX:7

IP Addr: 10.52.105.35

Subnet Mask: 255.255.255.0

Gateway: 0.0.0.0

CHAP Name: chapin

CHAP Secret: ********

 

Target Cfg:

Target Idx: 0

State: ISCSI_TARGET_READY

Prev State: ISCSI_TARGET_DISABLED

Target Error: ISCSI_TARGET_NO_ERROR

IQN: iqn.1992-08.com.netapp:sn.XXXXXXX

IP Addr: 1.1.1.1

Port: 3260

Boot Lun: 0

Ping Stats: Success (12.245ms)

 

Session Info:

session_id: 0

host_number: 0

bus_number: 0

target_id: 0

CHAP Name: chapout

CHAP Secret: ********

adapter 1/1/1 (mcp):3#